Archive for the ‘Excel formuły’ Category

Jak utworzyć własną formułę w Excelu

Tuesday, May 1st, 2012

Do tej pory często poruszałem temat procedur Sub, które wykonywały określone zadanie po czym ich rola zwykle się kończyła lub ograniczała się do wielokrotnego wykonania sekwencji identycznych czynności. Teraz omówię sposób utworzenia własnej formuły do zastosowania w komórkach Excela. Zakładam że masz problem ze znalezieniem tej właściwej formuły lub chcesz się po prostu dowiedzieć jak to zrobić.

Istotą działania formuły jest to że zwraca ona jakąś wartość w zależności od argumentów lecz niczego nie robi z formatem komórki.
Do utworzenia formuły potrzebujemy więc utworzenia funkcji w kodzie VBA. Robi się to podobnie jak w przypadku procedur Sub z tą różnicą że zamiast wyrażenia Sub nazwa () piszemy Function nazwa () funkcję zamykamy wyrażeniem End function

Mniej więcej tak

Function mojafunkcja () as Type
kod funkcji
End Function

oczywiście zamiast słowa type wpisujemy prawidłowy typ danych jaki ma zwracać nasza funkcja np Byte albo String albo Variant itp

i jeszcze coś ważnego:
zawsze przed słowami End Function przekazujemy wynik obliczeń lub działania formuły ze zmiennej do nazwy funkcji

wygląda to tak

Function mojafunkcja (jakaśzmienna1) as Type

‘coś tam się dzieje w naszej funkcji ze zmienną jakaśzmienna1

mojafunkcja=jakaśzmienna1
End Function

Przykładowa banalnie prosta funkcja zamieniająca mile na kilometry wyglądałaby tak

Function milenakm (mile as integer) as single
milenakm=mile*1,6
End function

Kod funkcji podobnie jak kod procedur Sub umieszczamy w Module VBE
ownformula1.png

ownformula2.png

ownformula3.png

ownformula4.png

ownformula5.png

W trakcie pisania artykułu posiłkowałem się tą książką
Vademecum Walkenbacha

Formuły tablicowe

Wednesday, April 25th, 2012

Formuły tablicowe nazywane są także formułami CSE od skrótu klawiszowego (Ctrl SHIFT Enter) jakiego należy użyć w celu ich uaktywnienia.
Czy formuły tablicowe to jakiś specjalny rodzaj formuł ?
I tak i nie - są to zwykłe funkcje Excelowe, z tą różnicą że kiedy chcemy ich używać warto odnosić ją do zakresów komórek zamiast pojedynczych komórek (nie jest to konieczne). Formuły takie są traktowane przez Excela jako tablicowe dopiero po oznaczeniu ich skrótem CSE.

Formuła tablicowa zadziała oczywiście nawet wtedy gdy zwykłą formułę oznaczymy jako CSE. Z kolei gdy użyjemy zakresu komórek a nie oznaczymy reguły jako tablicowej to pojawi się błąd (na przykład taki)

cseformula2err.png

Zaletą formuł tablicowych jest to że ułatwiają lub wręcz umożliwiają pewne obliczenia, które bez nich byłyby trudne. Zajmują one dużo mniej miejsca w pliku ze względu na fakt że dana reguła tablicowa obejmuje swym zasięgiem cały wskazany zakres komórek w przeciwieństwie do zwykłych formuł, które wpisujemy z osobna dla każdej komórki (możemy też przeciągnąć lub skopiować, ale rozmiarowo na jedno wychodzi).

Najczęstsze zastosowanie formuły tablicowe znajdują w ekonomii i analizie biznesowej, ale nic nie stoi na przeszkodzie aby użyć ich do tak prozaicznych celów jak szybkie wygenerowanie tabliczki mnożenia, symulacje obliczeniowe dla matematycznych modeli układów elektrycznych, podliczanie sprzedaży w sklepie i wszelkie raporty i podsumowania. Wynik formuły tablicowej może być wyświetlany w danym zakresie lub w jednej komórce. W przypadku wyniku wyświetlanego w zakresie komórek istotną zaletą jest brak możliwości przypadkowego skasowania formuły w jednej z komórek zakresu. Pojawi się wówczas komunikat że nie można zmienić części tablicy.

cseformula3err.png

Dopiero po zaznaczeniu całości obszaru objętego formułą da się skasować zawartość.

Formuła tablicowa pozwala uniknąć stosowania obliczeń pośrednich, które często stosują początkujący w Excelu (też do niedawna nie wyobrażałem sobie że można inaczej) a od których to obliczeń zwykle “puchnie” plik skoroszytu

Sposób zapisu formuły tablicowej
Przykładowo
=SUMA(JEŻELI(A1:A10>0,A1:A10,0))
Zaznaczamy całość i używamy skrótu Ctrl Shift Enter, w wyniku tego powyższy zapis zmieni się następująco
{=SUMA(JEŻELI(A1:A10>0,A1:A10,0))}
Ręczne wpisywanie nawiasów klamrowych mija się z celem i nie przyniesie żadnych rezultatów obliczeniowych
Powyższy przykład w anglojęzycznej wersji wygląda tak
{=SUM(IF(A1:A10>0;A1:A10;0))}

Dla przykładu mamy takie dane

cseformula1.png

Zauważmy że bez obliczeń pośrednich dla każdego wiersza od A1 do A10 Formuła wyliczyła prawidłowo sumę elementów, które spełniają warunek że liczby w tych komórkach są większe od zera. Chcąc to robić “na piechotę” musielibyśmy warunek taki skopiować w wierszach od B1 do B10 a dopiero wyniki podsumować. Jest to banalnie prosty przypadek, ale jest cała masa podobnych o nieco większej złożoności, które przydają się w codziennym życiu osób zajmujących się Excelem.

To na razie tyle odnośnie formuł tablicowych. Przypuszczalnie do tego tematu jeszcze nie jeden raz wrócę.