Archive for the ‘Ułatwienia’ Category

Excel 2010 - tworzenie makr

Thursday, July 15th, 2010

Ostatnio przeinstalowałem MS Office z wersji 2003 na wersję 2010. Oczywiście jedną z pierwszych czynności, którą zrobiłem po zainstalowaniu było sprawdzenie dostępu do funkcji które poprzednio mnie interesowały czyli formatowanie warunkowe, makra i reguły. Ponieważ menu jest znacząco przeorganizowane w stosunku do tego z wersji 2003 więc z początku miałem małe trudności, ale i tak trzeba przyznać że obsługa jest intuicyjna. Postaram się nieco o tym napisać w najbliższych dniach.
Na razie napiszę tylko jak dobrnąć do funkcji tworzenia makr.
Z funkcjami rejestracji makr można zacząć przygodę od użycia zakładki View

excel2010_tab_view1.png

W tym przypadku brakuje jednak możliwości tworzenia przycisków które uruchamiają makro. Aby mieć dostęp do szerszego pakietu funkcji związanych z makrami należy uaktywnić zakładkę Developer znajdującą się w zakładce File - options

excel2010_tab_file_options.png

Szczegółowo pokazane jest to poniżej - kliknij obrazek aby powiększyć.

excel2010_tab_file_options_developer.png

Warto korzystać z tej wersji. Sama obsługa makr nie różni się prawie niczym od wersji 2003.

Jedną rzeczą którą zauważyłem to rozdzielenie rodzajów plików wynikowych na te które są z makrami i na te które ich nie zawierają. Myślę że jest to dobre posunięcie ze strony Microsoftu.

Poniżej link do książki na temat poprzedniej wersji office. Kiedy pojawi się książka o aktualnej wersji dokonam podmiany linku.

Jak skierować kogoś do bezpośrednio do filmu w wersji HD na youtube

Tuesday, April 20th, 2010

Filmy umieszczane na youtube są dostępne zazwyczaj w kilku wersjach rozdzielczości, z kilku względów warto od razu obejrzeć tę najlepszą wersję, ale jak to zrobić ? - poniżej jest krótkie i proste rozwiązanie:
Do linku prowadzącego do filmu lub teledysku na youtube należy na końcu dodać kod:

&hd=1

Jak wycofać wiadomość z MS Outlook

Thursday, March 18th, 2010

Sposób dotyczy jedynie aplikacji będącej częścią pakietu Office nie ma on zastosowania w Outlook Express.
Jeśli wyślesz wiadomość i nie masz potwierdzenia że została ona przeczytana (czasem w ogóle nie ma takich potwierdzeń jeśli ktoś sobie je wyłączy) to możesz w razie potrzeby odwołać taką wiadomość. Jak to zrobić
Jeśli już wysłałeś wiadomość przejdź do katalogu Wysłane kliknij dwukrotnie na tę widomość tak aby otworzyła się w osobnym okienku a następnie przejdź do menu Akcje i wybierz pozycję Odwołaj tę wiadomość

Odwołanie wiadomości w MS Outlook

Pojawi się okienko z zapytaniem czy tylko ją odwołać czy odwołać i zastąpić nową oraz czy powiadamiać osobę do której email był wysłany o operacji odwołania. Tutaj jest dowolność ja zaznaczam opcje jak niżej chyba że sytuacja jest specyficzna i wymaga innych opcji.

Opcje odwołania wiadomości w MS Outlook

To wszystko :)

Excel - zliczanie wystąpień tekstu

Saturday, January 16th, 2010

Kiedyś pisałem o prostej metodzie zliczania ilości lub wartości komórek która polega na odczytaniu wartości w dolnym prawym rogu arkusza po zaznaczeniu grupy komórek. Nie wszystkie jednak wartości dają się w ten sposób policzyć. Poniżej przedstawiam metodę skuteczną w 100% choć wymagającą odrobinkę pracy. Zlicza ona z powodzeniem zarówno liczby jak i tekst a polega na specyficznym wykorzystaniu możliwości funkcji JEŻELI. Mianowicie funkcja jeżeli daje 1-kę w przypadku wystąpienia danego tekstu lub wartości a 0 (zero) w przypadku niewystąpienia poszczególne warunki trzeba umieścić odrębnych kolumnach a sumę jedynek zliczyć. PROSTE nieprawda ?
Przykład:
W kolumnie A występują w różnej ilości 3 imiona (np. Jan, Piotr, Celina) począwszy od komórki A2.
Chcąc zliczyć ilość wystąpień imienia Jan piszemy w kolumnie B lub kolejnej takie wyrażenie
= JEŻELI(A2=”Jan”,1,0) lub = JEŻELI(A2=”Jan”,1,) w kolejnych kolumnach to samo możemy zrobić dla pozostałych imion pamiętając aby w pierwszym wierszu obliczeń (tym samym co dla “Jan”) odnosić się do komórki A2 (a nie np B2) bo wyjdzie nie to co chcemy.
Gotowe warunki “przeciągamy” w dół aby obliczenia obowiązywały dla wszystkich wystąpień wyrazów a następnie podliczamy. Pokazałem to na rysunku poniżej.

sposób zliczenia wyrazów w Excelu

Powyższy przykład jest prosty ale możliwości tego typu rozwiązania są duże. Sam często stosowałem je w praktyce. Sama technika jest przejrzysta i łatwa do sprawdzenia. Polecam.

Dodatki Firefox - Autopager

Thursday, July 23rd, 2009

Dzisiaj zainteresowałem się kilkoma dodatkami firefoxa. Dawno tego nie robiłem, ale przy okazji aktualizacji Firefoxa skorzystałem ze strony informacyjnej trafiając na całkiem ciekawy dodatek o nazwie AutoPager. Pewnie każdy internauta prawie codzień korzysta z wyszukiwarek po przeglądnięciu kilku stron i klikaniu na numery kollejnych można mieć dość. Z pomocą przychodzi właśnie ten dodatek. Zadaniem jego jest ładowanie kolejnych stron np Google i wyświetlanie ich jako jednej strony przedzielonej liniami  i strzałkami nawigacyjnymi zgodnie z ilością linków wyświetlaną przez wyszukiwarkę.

autopager.png

Ilość opcji tego dodatku jest rozległa i trochę zajmie mi czasu zanim się w pełni zapoznam. Jeszcze w ciągu przyszłego tygodnia zechcę wrócić do jego opisu.
W tej chwili podaję jeszcze tylko link do dodatku
https://addons.mozilla.org/en-US/firefox/addon/4925